A vector can be hook normal if for a bar specified by index, the bar direction is not parallel with the vector.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barIndex
- Type: System Int32
The index of bar for which it will try to see if hook normal is applicable.
- end
- Type: System Int32
The end of bar. Should be 0 for start, 1 for end.
- normal
- Type: Autodesk.Revit.DB XYZ
The hook plane normal that will be tested.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |