CanBeHookNormal Method


Rebar Free Form Accessor Can Be Hook Normal Method

Note: This API is now obsolete.

A vector can be termination's (e.g. hook, crank) normal if for a bar specified by index, the bar direction is not parallel with the vector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarFreeFormAccessor.CanBeTerminationPlaneNormal instead.")]
public bool CanBeHookNormal(
	int barIndex,
	int end,
	XYZ normal
)

Parameters

barIndex Int32
The index of bar for which it will try to see if termination's plane normal is applicable.
end Int32
The end of bar. Should be 0 for start, 1 for end.
normal XYZ
The teriantion's (e.g. hook, crank) plane normal that will be tested.

Return Value

Boolean
A vector can be termination's (e.g. hook, crank) normal if for a bar specified by index, the bar direction is not parallel with the vector.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end.
See Also