CanBeHookNormal Method


A vector can be hook normal if for a bar specified by index, the bar direction is not parallel with the vector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public bool CanBeHookNormal(
	int barIndex,
	int end,
	XYZ normal
)
Visual Basic
Public Function CanBeHookNormal ( _
	barIndex As Integer, _
	end As Integer, _
	normal As XYZ _
) As Boolean
Visual C++
public:
bool CanBeHookNormal(
	int barIndex, 
	int end, 
	XYZ^ normal
)

Parameters

barIndex
Type: SystemInt32
The index of bar for which it will try to see if hook normal is applicable.
end
Type: SystemInt32
The end of bar. Should be 0 for start, 1 for end.
normal
Type: Autodesk.Revit.DBXYZ
The hook plane normal that will be tested.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also