Removed intersecting reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- intersectingReference
- Type: Autodesk.Revit.DB ElementId
Id of the intersecting reference to remove.
Return Value
True if the PartMaker used this intersecting reference and this call removed it, false if the PartMaker did not use this intersecting reference.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |