RemoveIntersectingReference Method


Removed intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool RemoveIntersectingReference(
	ElementId intersectingReference
)
Visual Basic
Public Function RemoveIntersectingReference ( _
	intersectingReference As ElementId _
) As Boolean
Visual C++
public:
bool RemoveIntersectingReference(
	ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DBElementId
Id of the intersecting reference to remove.

Return Value

True if the PartMaker used this intersecting reference and this call removed it, false if the PartMaker did not use this intersecting reference.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also