Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Namespace:
Autodesk.Revit.DB.IFC
Assembly:
RevitAPIIFC
(in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementHandle
-
Type:
Autodesk.Revit.DB.IFC
IFCAnyHandle
The IfcElement handle.
- pLevelInfo
-
Type:
Autodesk.Revit.DB.IFC
IFCLevelInfo
The level info.
- params
-
Type:
Autodesk.Revit.DB.IFC
IFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be a null reference ( Nothing in Visual Basic) .
- relateToLevel
-
Type:
System
Boolean
True to relate the element to the level, false otherwise.
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |