AddElement Method


Adds an IfcElement handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void AddElement(
	IFCAnyHandle elementHandle,
	IFCLevelInfo pLevelInfo,
	IFCExtrusionCreationData params,
	bool relateToLevel
)
Visual Basic
Public Sub AddElement ( _
	elementHandle As IFCAnyHandle, _
	pLevelInfo As IFCLevelInfo, _
	params As IFCExtrusionCreationData, _
	relateToLevel As Boolean _
)
Visual C++
public:
void AddElement(
	IFCAnyHandle^ elementHandle, 
	IFCLevelInfo^ pLevelInfo, 
	IFCExtrusionCreationData^ params, 
	bool relateToLevel
)

Parameters

elementHandle
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The IfcElement handle.
pLevelInfo
Type: Autodesk.Revit.DB.IFCIFCLevelInfo
The level info.
params
Type: Autodesk.Revit.DB.IFCIFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be a null reference (Nothing in Visual Basic).
relateToLevel
Type: SystemBoolean
True to relate the element to the level, false otherwise.

Remarks

If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also