AddElement Method


IFCProduct Wrapper Add Element Method

Adds an IfcElement handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddElement(
	IFCAnyHandle elementHandle,
	IFCLevelInfo pLevelInfo,
	IFCExtrusionCreationData params,
	bool relateToLevel
)

Parameters

elementHandle IFCAnyHandle
The IfcElement handle.
pLevelInfo IFCLevelInfo
The level info.
params IFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be .
relateToLevel Boolean
True to relate the element to the level, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
See Also