Breaks the pipe curve into two parts at the given position.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- pipeId
- Type: Autodesk.Revit.DB ElementId
The element id of the pipe curve to break.
- ptBreak
- Type: Autodesk.Revit.DB XYZ
The break point on the pipe curve.
Return Value
The new pipe curve element id if successful otherwise if a failure occurred an invalidElementId is returned.Remarks
This method is not applicable for breaking the flex pipe.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | "The element is neither a pipe nor a pipe placeholder." -or- "The given point is not on the pipe curve." |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |