BreakCurve Method


Plumbing Utils Break Curve Method

Breaks the pipe curve into two parts at the given position.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId BreakCurve(
	Document document,
	ElementId pipeId,
	XYZ ptBreak
)

Parameters

document Document
The document.
pipeId ElementId
The element id of the pipe curve to break.
ptBreak XYZ
The break point on the pipe curve.

Return Value

ElementId
The new pipe curve element id if successful otherwise if a failure occurred an invalidElementId is returned.
Exceptions
Exception Condition
ArgumentException "The element is neither a pipe nor a pipe placeholder." -or- "The given point is not on the pipe curve."
ArgumentNullException A non-optional argument was null
Remarks
This method is not applicable for breaking the flex pipe.
See Also