Breaks the pipe curve into two parts at the given position.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- pipeId
- Type: Autodesk.Revit.DBElementId
The element id of the pipe curve to break.
- ptBreak
- Type: Autodesk.Revit.DBXYZ
The break point on the pipe curve.
Return Value
The new pipe curve element id if successful otherwise if a failure occurred an invalidElementId is returned.Remarks
This method is not applicable for breaking the flex pipe.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | "The element is neither a pipe nor a pipe placeholder." -or- "The given point is not on the pipe curve." |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |