AddSpaces Method


Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public bool AddSpaces(
	SpaceSet spaces
)
Visual Basic
Public Function AddSpaces ( _
	spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool AddSpaces(
	SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.DB.Mechanical SpaceSet
The spaces which want to add to zone element.

Return Value

If successful the current zone element will add a set of input spaces, otherwise a null reference ( Nothing in Visual Basic) .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the specified parameter Value is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the input spaces cannot be added to current zone element.

See Also