AddSpaces Method


Zone Add Spaces Method

Note: This API is now obsolete.

Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a future version of Revit. Please use the GenericZone object instead.")]
public bool AddSpaces(
	SpaceSet spaces
)

Parameters

spaces SpaceSet
The spaces which want to add to zone element.

Return Value

Boolean
If successful the current zone element will add a set of input spaces, otherwise .
Exceptions
Exception Condition
ArgumentNullException Thrown when the specified parameter Value is .
InvalidOperationException Thrown when the input spaces cannot be added to current zone element.
See Also