Add a set of existing spaces to Zone element.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spaces
- Type: Autodesk.Revit.DB.MechanicalSpaceSet
The spaces which want to add to zone element.
Return Value
If successful the current zone element will add a set of input spaces, otherwise a null reference (Nothing in Visual Basic).Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the specified parameter Value is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the input spaces cannot be added to current zone element. |