CanSetValue Method (ElementId)


Checks whether StorageType of entry is ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public bool CanSetValue(
	ElementId value
)
Visual Basic
Public Function CanSetValue ( _
	value As ElementId _
) As Boolean
Visual C++
public:
bool CanSetValue(
	ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB ElementId
New ElementId value.

Return Value

True if StorageType of the entry is ElementId and the entry, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also