CanSetValue Method (ElementId)


Checks whether StorageType of entry is ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public bool CanSetValue(
	ElementId value
)
Visual Basic
Public Function CanSetValue ( _
	value As ElementId _
) As Boolean
Visual C++
public:
bool CanSetValue(
	ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DBElementId
New ElementId value.

Return Value

True if StorageType of the entry is ElementId and the entry, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also