Constructor that takes the frame's base point and three basis vectors.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- origin
- Type: Autodesk.Revit.DB XYZ
The frame's base point.
- vec1
- Type: Autodesk.Revit.DB XYZ
The frame's first basis vector.
- vec2
- Type: Autodesk.Revit.DB XYZ
The frame's second basis vector.
- vec3
- Type: Autodesk.Revit.DB XYZ
The frame's third basis vector.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |