Frame Constructor (XYZ, XYZ, XYZ, XYZ)


Frame(XYZ, XYZ, XYZ, XYZ) Constructor

Constructor that takes the frame's base point and three basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Frame(
	XYZ origin,
	XYZ vec1,
	XYZ vec2,
	XYZ vec3
)

Parameters

origin XYZ
The frame's base point.
vec1 XYZ
The frame's first basis vector.
vec2 XYZ
The frame's second basis vector.
vec3 XYZ
The frame's third basis vector.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also