Constructor that takes the frame's base point and three basis vectors.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- origin
- Type: Autodesk.Revit.DBXYZ
The frame's base point.
- vec1
- Type: Autodesk.Revit.DBXYZ
The frame's first basis vector.
- vec2
- Type: Autodesk.Revit.DBXYZ
The frame's second basis vector.
- vec3
- Type: Autodesk.Revit.DBXYZ
The frame's third basis vector.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |