Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.
If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId .