Parameter |
Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ParameterValueProvider type exposes the following members.

Name | Description | |
---|---|---|
![]() | ParameterValueProvider | Constructs an instance of ParameterValueProvider. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterableValueProvider ) |
![]() | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from FilterableValueProvider ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element. (Inherited from FilterableValueProvider ) |
![]() | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider ) |
![]() | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider ) |
![]() | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider ) |
![]() | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider ) |
![]() | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider ) |
![]() | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.
If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId .