Parameter |
Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ParameterValueProvider type exposes the following members.

Name | Description | |
---|---|---|
![]() | ParameterValueProvider | Constructs an instance of ParameterValueProvider. |

Name | Description | |
---|---|---|
![]() | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element. |

Name | Description | |
---|---|---|

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.
If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId .