ParameterValueProvider Class


Parameter Value Provider Class

Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterableValueProvider
Autodesk.Revit.DB ParameterValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ParameterValueProvider : FilterableValueProvider

The ParameterValueProvider type exposes the following members.

Constructors
Name Description
Public method ParameterValueProvider Constructs an instance of ParameterValueProvider.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterableValueProvider )
Public property Parameter The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterableValueProvider )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAssociatedGlobalParameterValue Gets a global parameter value associated with a parameter from the given element.
(Inherited from FilterableValueProvider )
Public method GetDoubleValue Gets a double-precision numeric value from the given element.
(Inherited from FilterableValueProvider )
Public method GetElementIdValue Gets an ElementId value from the given element.
(Inherited from FilterableValueProvider )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetIntegerValue Gets an integer value from the given element.
(Inherited from FilterableValueProvider )
Public method GetStringValue Gets a string value from the given element.
(Inherited from FilterableValueProvider )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsDoubleValueSupported Determines whether the provide can provide a double-precision numeric value for the given element.
(Inherited from FilterableValueProvider )
Public method IsElementIdValueSupported Determines whether the provide can provide an ElementId value for the given element.
(Inherited from FilterableValueProvider )
Public method IsIntegerValueSupported Determines whether the provide can provide an integer value for the given element.
(Inherited from FilterableValueProvider )
Public method IsStringValueSupported Determines whether the provide can provide a string value for the given element.
(Inherited from FilterableValueProvider )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.

If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId .

See Also