A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetViewType
- Type: Autodesk.Revit.DB DirectShapeTargetViewType
View type for which this shape representation is intended. Currently limited to Plan Views.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |