ViewShapeBuilder Constructor (DirectShapeTargetViewType)


A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public ViewShapeBuilder(
	DirectShapeTargetViewType targetViewType
)
Visual Basic
Public Sub New ( _
	targetViewType As DirectShapeTargetViewType _
)
Visual C++
public:
ViewShapeBuilder(
	DirectShapeTargetViewType targetViewType
)

Parameters

targetViewType
Type: Autodesk.Revit.DBDirectShapeTargetViewType
View type for which this shape representation is intended. Currently limited to Plan Views.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException targetViewType is not DirectShapeTargetViewType::Plan
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also