View |
A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- targetViewType DirectShapeTargetViewType
- View type for which this shape representation is intended. Currently limited to Plan Views.

Exception | Condition |
---|---|
ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |