Remove the given LightGroup object from the set of LightGroup objects
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- groupId
- Type: Autodesk.Revit.DB ElementId
The Id of the LightGroup object to remove
Remarks
Note that only the group is deleted, not the lights contained in the group The lights will still exist but will not be in a group any longer
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given element Id does not correspond to a light group -or- The LightGroup is not contained by this LightGroupManager |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |