DeleteGroup Method


Remove the given LightGroup object from the set of LightGroup objects

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void DeleteGroup(
	ElementId groupId
)
Visual Basic
Public Sub DeleteGroup ( _
	groupId As ElementId _
)
Visual C++
public:
void DeleteGroup(
	ElementId^ groupId
)

Parameters

groupId
Type: Autodesk.Revit.DBElementId
The Id of the LightGroup object to remove

Remarks

Note that only the group is deleted, not the lights contained in the group The lights will still exist but will not be in a group any longer

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given element Id does not correspond to a light group -or- The LightGroup is not contained by this LightGroupManager
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also