DeleteGroup Method


Light Group Manager Delete Group Method

Remove the given LightGroup object from the set of LightGroup objects

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void DeleteGroup(
	ElementId groupId
)

Parameters

groupId ElementId
The Id of the LightGroup object to remove
Exceptions
Exception Condition
ArgumentException The given element Id does not correspond to a light group -or- The LightGroup is not contained by this LightGroupManager
ArgumentNullException A non-optional argument was null
Remarks
Note that only the group is deleted, not the lights contained in the group The lights will still exist but will not be in a group any longer
See Also