Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- forSlantedColumn
- Type: System Boolean
If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
- target
- Type: Autodesk.Revit.DB Element
A proposed target element for a column attachment.
Remarks
Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |