Column |
Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- forSlantedColumn Boolean
- If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
- target Element
- A proposed target element for a column attachment.
Return Value
Boolean
Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.