Says whether the element can be used as a target for a new attachment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- forSlantedColumn
- Type: SystemBoolean
If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
- target
- Type: Autodesk.Revit.DBElement
A proposed target element for a column attachment.
Remarks
Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |