Determines if the given reference can be set for the given end of the framing element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyInstance
- Type: Autodesk.Revit.DB FamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete and joined at the given end.
- end
- Type: System Int32
The index of the end (0 for the start, 1 for the end).
- pick
- Type: Autodesk.Revit.DB Reference
The reference to be checked against the given end of the framing element.
Return Value
True if the given reference can be set for the given end of the framing element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | end must be 0 or 1. |