IsEndReferenceValid Method


Determines if the given reference can be set for the given end of the framing element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static bool IsEndReferenceValid(
	FamilyInstance familyInstance,
	int end,
	Reference pick
)
Visual Basic
Public Shared Function IsEndReferenceValid ( _
	familyInstance As FamilyInstance, _
	end As Integer, _
	pick As Reference _
) As Boolean
Visual C++
public:
static bool IsEndReferenceValid(
	FamilyInstance^ familyInstance, 
	int end, 
	Reference^ pick
)

Parameters

familyInstance
Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete and joined at the given end.
end
Type: SystemInt32
The index of the end (0 for the start, 1 for the end).
pick
Type: Autodesk.Revit.DBReference
The reference to be checked against the given end of the framing element.

Return Value

True if the given reference can be set for the given end of the framing element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException end must be 0 or 1.

See Also