IsEndReferenceValid Method


Structural Framing Utils Is End Reference Valid Method

Determines if the given reference can be set for the given end of the framing element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsEndReferenceValid(
	FamilyInstance familyInstance,
	int end,
	Reference pick
)

Parameters

familyInstance FamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete and joined at the given end.
end Int32
The index of the end (0 for the start, 1 for the end).
pick Reference
The reference to be checked against the given end of the framing element.

Return Value

Boolean
True if the given reference can be set for the given end of the framing element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
See Also