Get the material painted on the element's face. Returns invalidElementId if the face is not painted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementId
- Type: Autodesk.Revit.DB ElementId
The element that the face belongs to.
- face
- Type: Autodesk.Revit.DB Face
The painted element's face.
Return Value
The material's Id painted on the element's face.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |