GetPaintedMaterial Method


Document Get Painted Material Method

Get the material painted on the element's face. Returns invalidElementId if the face is not painted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId GetPaintedMaterial(
	ElementId elementId,
	Face face
)

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.

Return Value

ElementId
The material's Id painted on the element's face.
Exceptions
Exception Condition
ArgumentException The element elementId does not exist in the document -or- The face doesn't belong to the element
ArgumentNullException A non-optional argument was null
See Also