GetPaintedMaterial Method


Get the material painted on the element's face. Returns invalidElementId if the face is not painted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public ElementId GetPaintedMaterial(
	ElementId elementId,
	Face face
)
Visual Basic
Public Function GetPaintedMaterial ( _
	elementId As ElementId, _
	face As Face _
) As ElementId
Visual C++
public:
ElementId^ GetPaintedMaterial(
	ElementId^ elementId, 
	Face^ face
)

Parameters

elementId
Type: Autodesk.Revit.DBElementId
The element that the face belongs to.
face
Type: Autodesk.Revit.DBFace
The painted element's face.

Return Value

The material's Id painted on the element's face.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The element elementId does not exist in the document -or- The face doesn't belong to the element
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also