SetIntermediateColors Method


Set intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public void SetIntermediateColors(
	IList<AnalysisDisplayColorEntry> map
)
Visual Basic
Public Sub SetIntermediateColors ( _
	map As IList(Of AnalysisDisplayColorEntry) _
)
Visual C++
public:
void SetIntermediateColors(
	IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic IList AnalysisDisplayColorEntry
Array of intermediate color entries.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException intermediate color entries with specific values are not ordered by value (min to max) or too many intermediate colors (>100).
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also