SetIntermediateColors Method


Analysis Display Color Settings Set Intermediate Colors Method

Set intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetIntermediateColors(
	IList<AnalysisDisplayColorEntry> map
)

Parameters

map IList AnalysisDisplayColorEntry
Array of intermediate color entries.
Exceptions
Exception Condition
ArgumentException intermediate color entries with specific values are not ordered by value (min to max) or too many intermediate colors (>100).
ArgumentNullException A non-optional argument was null
See Also