Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- typeList
- Type: System.Collections.Generic IList Type
The list of Element subclass types to match.
- inverted
- Type: System Boolean
True if the filter should match all elements which are not of the given Element subclass.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |