ElementMulticlassFilter Constructor (IList(Type), Boolean)


Element Multiclass Filter(IList Type , Boolean) Constructor

Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementMulticlassFilter(
	IList<Type> typeList,
	bool inverted
)

Parameters

typeList IList Type
The list of Element subclass types to match.
inverted Boolean
True if the filter should match all elements which are not of the given Element subclass.
Exceptions
Exception Condition
ArgumentException One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
ArgumentNullException A non-optional argument was null
See Also