Gets the BuiltInCategory value corresponding to the given built-in category identifier.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
The built-in category identifier.
Return Value
The BuiltInCategory value corresponding to the given built-in category identifier.Remarks
A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | categoryTypeId is not a built-in category identifier. See Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |