Category Get |
Gets the BuiltInCategory value corresponding to the given built-in category identifier.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- categoryTypeId ForgeTypeId
- The built-in category identifier.
Return Value
BuiltInCategoryThe BuiltInCategory value corresponding to the given built-in category identifier.

Exception | Condition |
---|---|
ArgumentException | categoryTypeId is not a built-in category identifier. See Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory). |
ArgumentNullException | A non-optional argument was null |

A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory) .