GetBuiltInCategory Method


Category Get Built In Category Method

Gets the BuiltInCategory value corresponding to the given built-in category identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BuiltInCategory GetBuiltInCategory(
	ForgeTypeId categoryTypeId
)

Parameters

categoryTypeId ForgeTypeId
The built-in category identifier.

Return Value

BuiltInCategory
The BuiltInCategory value corresponding to the given built-in category identifier.
Exceptions
Exception Condition
ArgumentException categoryTypeId is not a built-in category identifier. See Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
ArgumentNullException A non-optional argument was null
Remarks
A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory) .
See Also