Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
A document.
- paramId
- Type: Autodesk.Revit.DB ElementId
The id of a shared parameter in the document.
- definitionFile
- Type: Autodesk.Revit.DB DefinitionFile
A database of shared parameters.
Return Value
The external parameter corresponding to the parameter's ElementId, or null if the Id does not correspond to an external parameter, or the parameter is not in the definition file.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was a null reference ( Nothing in Visual Basic) . |