GetExternalDefinitionForElementId Method


Rebar Shape Parameters Get External Definition For Element Id Method

Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ExternalDefinition GetExternalDefinitionForElementId(
	Document doc,
	ElementId paramId,
	DefinitionFile definitionFile
)

Parameters

doc Document
A document.
paramId ElementId
The id of a shared parameter in the document.
definitionFile DefinitionFile
A database of shared parameters.

Return Value

ExternalDefinition
The external parameter corresponding to the parameter's ElementId, or null if the Id does not correspond to an external parameter, or the parameter is not in the definition file.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was .
See Also