Creates a new tab on the Revit user interface.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- tabName
- Type: System String
The name of the tab to be created.
Remarks
This method will create a custom tab at the end of the list of static tabs. If multiple tabs are added, they will be shown in the order added. This method is not supported in Macros.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | tabName or panelName is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | tabName or panelName is Empty or the tab name duplicates the name of another tab in the Revit UI. |
Autodesk.Revit.Exceptions InvalidOperationException | Too many custom tabs have been created in this session. (Maximum is 20). |