CreateRibbonTab Method


UIApplication Create Ribbon Tab Method

Creates a new tab on the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual void CreateRibbonTab(
	string tabName
)

Parameters

tabName String
The name of the tab to be created.
Exceptions
Exception Condition
ArgumentNullException tabName or panelName is .
ArgumentException tabName or panelName is Empty or the tab name duplicates the name of another tab in the Revit UI.
InvalidOperationException Too many custom tabs have been created in this session. (Maximum is 20).
Remarks
This method will create a custom tab at the end of the list of static tabs. If multiple tabs are added, they will be shown in the order added. This method is not supported in Macros.
See Also