CreateRibbonTab Method


Creates a new tab on the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public virtual void CreateRibbonTab(
	string tabName
)
Visual Basic
Public Overridable Sub CreateRibbonTab ( _
	tabName As String _
)
Visual C++
public:
virtual void CreateRibbonTab(
	String^ tabName
)

Parameters

tabName
Type: SystemString
The name of the tab to be created.

Remarks

This method will create a custom tab at the end of the list of static tabs. If multiple tabs are added, they will be shown in the order added. This method is not supported in Macros.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptiontabName or panelName is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptiontabName or panelName is Empty or the tab name duplicates the name of another tab in the Revit UI.
Autodesk.Revit.ExceptionsInvalidOperationExceptionToo many custom tabs have been created in this session. (Maximum is 20).

See Also