Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- index
- Type: System Int32
0 for the starting hook, 1 for the ending hook.
Remarks
Replaces the method GetHookAngle() from prior releases.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | index must be 0 or 1. |